Ionic j2store
Search…
Environment Setup

Website Requirements

J2store
3.3.6 or higher
Joomla
3.5 or higher
PHP
7.0 or higher
Install Components and Plugins to your website
  • Login as Administrator and then Simply choose Extensions → Manage → Install in any back-end page to install components, and plug-ins.
  • In the Upload Package File section, click the "Drag and drop file here" section to browse to and select the component file on your hard drive
  • After upload the plugins installation will be start. When it finishes, it displays a message telling you that installation was successful.
Note : If you Install Plugin don't forget to Enable it.

Enable Plugins in Joomla

  • To enable a plugin, log in to the admin panel of your Joomla site and click on the Extension -> Plugins option from the top navigation bar.
  • On this page, you will see a list of plugins available for your Joomla site. You can also search and sort the plugins to find whatever you want.
  • For instance, Let’s say we want to enable the J2Store RESTful API on our site. To enable the J2Store RESTful API plugin, just find it in the list.
  • select it using the checkbox given in the first column of the table and then click on the Enable button given at the top-left corner of the page.
  • Once the plugin is enabled, you will see a success message.
Get Rest API Client Id and Secret Key :
  • After Enabled J2Store RESTful API plugin, click on the J2Store RESTful API get Client Id and Secret Key Informations

Configure Firebase Auth Key in Website

  • Goto Administrator and then Simply choose Components → J2MobApp → Settings
  • Enter your firebase auth key
  • After configured, you will send notification to your users.

To get started with Ionic Framework, the only requirement is a Node, npm environment & a code editor.

Node & npm

  1. 1.
    Download the node from the following URL https://nodejs.org/en/download
  2. 2.
    We recommend selecting the LTS version to ensure the best compatibility.
  3. 3.
    A code editor for writing code https://code.visualstudio.com
  4. 4.
    To verify the installation, open a new terminal window and run:
1
$ node --version
Copied!
1
$ npm --version
Copied!
Last modified 3mo ago
Copy link